[Officiel] Fin du support PHP 4 pour TYPO3

Publié le

Michael Stucki l’a confirmé… La prochaine version de TYPO3, la version 4.2 nécessitera l’installation de PHP 5 sur votre serveur.
PHP 6 va bientôt arriver et il se serait un perte de temps assez importante que d’assurer un support sur un ancienne version de PHP. Vérifiez donc la compatibilité de vos extensions ‘maison’ avec PHP 5, surtout si vous utilisez de la POO ou bien de la gestion de flux XML.

Source :
Hi guys,

as we already discussed off-list, I have now announced that we are going to
require PHP5 for TYPO3 4.2.

This means that from now on, you are free to use PHP 5 specific features in
Trunk (only Trunk for now!)

However, please acknowledge the statement about PHP 5.1 below. For now we
should avoid using any features that were introduced in PHP 5.2, at least
until those enterprise products have reached this version.

See full blog post:
http://buzz.typo3.org/people/stucki/article/leaving-php4-behind/

Publicités